Tuesday, 27 February 2024

an error occurred while installing psych (5.1.2) and bundler cannot continue. windows. Error with psych gem in Ruby on rails

 An error occurred while installing psych (5.1.2), and Bundler cannot continue.

The psych gem does neither install nor run the bundle, In this context I followed the following steps to rectify this error:

1. Update the gems using the following command

gem update

2. bundle install --gemfile

3.  gem update psych --platform=ruby

4. bundle install

5. gem update --system

6. gem pristine openssl --version 3.2.0

7.  Add the below line to the end of your GEMFILE

gem 'psych', '5.1.1'

Then Run the bundle install

bundle i


Tuesday, 24 May 2022

Sales by Match problem solved using c++

 There is a large pile of socks that must be paired by color. Given an array of integers representing the color of each sock, determine how many pairs of socks with matching colors there are.

Example

There is one pair of color  and one of color . There are three odd socks left, one of each color. The number of pairs is .

Function Description

Complete the sockMerchant function in the editor below.

sockMerchant has the following parameter(s):

  • int n: the number of socks in the pile
  • int ar[n]: the colors of each sock

Returns

  • int: the number of pairs

Input Format

The first line contains an integer , the number of socks represented in .
The second line contains  space-separated integers, , the colors of the socks in the pile.

Constraints

  •  where 

Sample Input

STDIN                       Function
-----                       --------
9                           n = 9
10 20 20 10 10 30 50 10 20  ar = [10, 20, 20, 10, 10, 30, 50, 10, 20]

Sample Output

3

Explanation

sock.png

There are three pairs of socks.


Solution:


#include <bits/stdc++.h>


using namespace std;


string ltrim(const string &);

string rtrim(const string &);

vector<string> split(const string &);


/*

 * Complete the 'sockMerchant' function below.

 *

 * The function is expected to return an INTEGER.

 * The function accepts following parameters:

 *  1. INTEGER n

 *  2. INTEGER_ARRAY ar

 */


int sockMerchant(int n, vector<int> ar) {

int cnt=0;

int i=0,j=0;

for(i=0;i<n;i++){

    for(j=i+1;j<n;j++)

    if(ar[i]<ar[j]){

        cnt=ar[i];

        ar[i]=ar[j];

        ar[j]=cnt;

    }

}


cnt=0;

for(i=0;i<n;i++){

j=i+1;

if((i==n)||(j>=n))

break;

if(ar[i]==ar[j]){

    cnt++;

    i=j;

}

}

cout << "total count:" <<cnt;

return cnt;

}


int main()

{

    ofstream fout(getenv("OUTPUT_PATH"));


    string n_temp;

    getline(cin, n_temp);


    int n = stoi(ltrim(rtrim(n_temp)));


    string ar_temp_temp;

    getline(cin, ar_temp_temp);


    vector<string> ar_temp = split(rtrim(ar_temp_temp));


    vector<int> ar(n);


    for (int i = 0; i < n; i++) {

        int ar_item = stoi(ar_temp[i]);


        ar[i] = ar_item;

    }


    int result = sockMerchant(n, ar);


    fout << result << "\n";


    fout.close();


    return 0;

}


string ltrim(const string &str) {

    string s(str);


    s.erase(

        s.begin(),

        find_if(s.begin(), s.end(), not1(ptr_fun<int, int>(isspace)))

    );


    return s;

}


string rtrim(const string &str) {

    string s(str);


    s.erase(

        find_if(s.rbegin(), s.rend(), not1(ptr_fun<int, int>(isspace))).base(),

        s.end()

    );


    return s;

}


vector<string> split(const string &str) {

    vector<string> tokens;


    string::size_type start = 0;

    string::size_type end = 0;


    while ((end = str.find(" ", start)) != string::npos) {

        tokens.push_back(str.substr(start, end - start));


        start = end + 1;

    }


    tokens.push_back(str.substr(start));


    return tokens;

}


Tree: Level Order Traversal solved in c++

 Given a pointer to the root of a binary tree, you need to print the level order traversal of this tree. In level-order traversal, nodes are visited level by level from left to right. Complete the function  and print the values in a single line separated by a space.

For example:

     1
      \
       2
        \
         5
        /  \
       3    6
        \
         4  

For the above tree, the level order traversal is .

Input Format

You are given a function,

void levelOrder(Node * root) {

}

Constraints

 Nodes in the tree  

Output Format

Print the values in a single line separated by a space.

Sample Input

     1
      \
       2
        \
         5
        /  \
       3    6
        \
         4  

Sample Output

1 2 5 3 6 4

Explanation

We need to print the nodes level by level. We process each level from left to right.
Level Order Traversal: .


Solution :


/*

class Node {

    public:

        int data;

        Node *left;

        Node *right;

        Node(int d) {

            data = d;

            left = NULL;

            right = NULL;

        }

};

*/


  int height(Node *root){

      if(root==NULL)

      return 0;

      

      return 1+max(height(root->left),height(root->right));

  }


    void levelOrder(Node * root) {

       int h = height(root);

       for(int d=1;d<=h;d++)

         printLevelOrder(root,d);

         

    }

    

    void printLevelOrder(Node* root,int l){

        if(root==NULL)

         return;

         

            if(l==1)

             cout<<root->data<<" ";

            else{

                printLevelOrder(root->left,l-1);

                printLevelOrder(root->right,l-1);

            }

             

         

    }